Archive for the ‘周辺機器’ Category

W-ZERO3[WS011SH]XDA Facebook

3月 13th, 2011 by marumi | No Comments | Filed in 周辺機器

PHS回線ではFacebookにログインできない。
無線LANではログイン可能。

Willcomに問い合せたところ、調査して解答を送って頂けた。
Facebookが電話機側に個体識別情報の送信を求めているため、こちらの情報を返さないWillcomの電話機ではログインが出来ず、結果としてエラーになってしまうとのこと。
つまり、Facebook側で対応してくれないとダメ。
Facebookにもこれを問い合わせの形で送ってみたが、返事はない。
対応策を捜すと、Twitterで「[XDA Facebook]でなら繋がった」という情報を見つけたので試してみました。

インストールするには、[.NET Compact Framework]が必要とメッセージが出ました。
.NET Compact Framework 3.5 再頒布可能パッケージ
W-ZERO3をActiveSyncで接続して、「NETCFSetupv35.msi」をインストールすれば良いのです。
↓参考(感謝です)
京ぽん、W-ZERO3徹底活用

でも、私のメインPCはUbuntu。
調べたところ、Ubuntuでも何とかできました。
まず、wineで「NETCFSetupv35.msi」をインストール。
wine上の「c:¥Program Files¥Microsoft.NET¥SDK¥CompactFramework¥v3.5¥WindowsCE
NETCFv35.wm.armv4i.cab」を、Dropboxを経由してW-ZERO3にコピーしてインストールしました。

次に「XDA Facebook」のインストール。
PHS回線ではやはりログインできず、「Unknown error」が出る。
が、一旦無線LANで接続しログインした後、一度アプリを終了し、PHS回線で繋ぎ直すとそのままログイン状態を維持できていた。
アドエスをOFFした後でも大丈夫。
ところどころ「coming soon」なので、気長に待とうと思う。
Willcomさんもちゃんと調査してくれたので、この情報も送っておこう。

※ ここまで書いて、Twitterでこのソフトを教えてくださった方の記事を見つけました(感謝)。
willcom03で(PHS回線で)XDA Facebookを使う

Tags: , ,

[Ubuntu10.10]ネットワークHDDのマウント

1月 4th, 2011 by marumi | No Comments | Filed in 周辺機器

BuffaloのネットワークHDD「LS-CHL550」を起動時マウントする設定にしていたのが、Ubuntuを9.10→10.10にUPしたらマウントされなくなりました。
sambaでは接続でき、日本語表示も、読み書きも問題ありません。

Ubuntu10.04で設定したときは、↓こうでした。

[Ubuntu9.10]ネットワークHDDマウント設定
fstabに下記のように自動mountを設定して使えていたのですが、なぜかダメ。

//(HDDのIPアドレス)/share /media/HDD50/ smbfs codepage=cp932,iocharset=utf8,rw,uid=(自分のユーザ名),gid=(自分のユーザ名) defaults 0 0

いろいろ調べて下記のサイトを参考に(感謝)。

ubuntu10.10でファイルシステムにNASをマウントする方法

smbfsではなく、cifsで接続。
下記の記述にてマウントできました。 ↓

//(HDDのIPアドレス)/share /media/HDD55/ cifs username=(ユーザー名),password=(パスワード),iocharset=utf8,rw,uid=(ユーザ名),gid=(ユーザ名) defaults 0 0

ついでに、余っている古めのネットワークHDD「HD-HLAN14B」もマウントを試みましたが、こちらはsmbでも文字化けしており、sifsでも、smbfsでも読み取り専用になってしまいます。
これはまたの機会に。

== 追記 ================================================
再度落ち着いてトライしたら、古めのHDDもマウントはできました。
ただ、日本語ファイル名が文字化けします。

上記、smbでも文字化けするのは、以前にも対応済みでした。
ネットでググッてて自分のブログを発見(おいっ)。
ネットワークHDDの文字化け

sudo gedit /etc/samba/smb.conf
で [global]の下くらいに以下を貼り付け。
dos charset = CP932
unix charset = UTF-8
display charset = UTF-8

ただ、起動時のマウントではやっぱり文字化けします。
ログを確認すると、

kernel: [   23.942102] CIFS: Unknown mount option codepage

「codepageなんてオプションは知らん」って意味でしょうか。
どうやら「smbfs」にあった「codepage」のオプションは無いらしい。

Tags: , , ,

[Ubuntu10.10]iPodを接続

12月 16th, 2010 by marumi | No Comments | Filed in 周辺機器

Clementine」が良いとの記事を読み、さっそくインストールを試みましたが、iPodを接続すると複数のエラーが。
試しに標準の「Rhythmbox」を起動してみると、ちゃんと音楽が流れます。
で、「MPEG-4 AACデコーダー」が無いと文句を言うので画面に従ってインストール。
「gstreamer0.10-ffmpeg」
「gstreamer0.10-plugins-bad」
が入りました。
もう一度「Clementine」に戻ってみると、同じ曲が再生不可です。

そうそうこれらはiTunes storeで購入した曲でした。
「ストリームは暗号化をサポートしていません、このファイルには再生不可能なストリームが含まれています」。
「Fairplay」DRM(デジタル著作権管理機能)ですね。

Ubuntuも、前のバージョンに比べて本当に簡単になりました。

Tags: , , ,

【Ubuntu9.10】CANON MX870セットアップ

11月 9th, 2010 by marumi | No Comments | Filed in 周辺機器

HP複合機が壊れたので、「CANON MX870」に買い換えました。
ネットワーク接続の複合機です。うちでは有線LAN接続。
まずは、Windowsパソコンからネットワーク設定を済ませます。
メーカーがドライバを提供しています。
プリンタもスキャナも使用可能。
IJ Printer Driver Ver.3.30 for Linux
ScanGear MP Ver1.50 for Linux (Scanner Driver)
これで簡単に済めば良かったのですが、結構手こずりました。
取説に従って、

tar zxvf cnijfilter-mx870series-3.30-1-i386-deb.tar.gz
cd cnijfilter-mx870series-3.30-1-i386-deb
sudo ./install.sh

プリンタ・スキャナどちらのドライバも、インストールしようとすると、「エラーが発生しました。パッケージ管理システムが特定できません」と出て、インストールできません。
試しに古いバージョンのドライバを試みても、「Error! Cannot specify package management」と出ます。
Ubuntu日本語フォーラムに投稿して、助けていただきました。
CANON MX870のドライバをインストールできません

いろいろ試しましたが、結局
Subject: RE: How do I get my MX870 Canon Printer to work with ubuntu? => [SOLVED] – msg#03338
↑こちらの情報どおり、

3. Double-click on cnijfilter-common_3.30-1_i386.deb and install.
4. Double-click on cnijfilter-mx870series_3.30-1_i386.deb and install.

これでインストールできました。
4はやってみたのですが、3の共通ファイルを先にインストールしなければいけなかったようです。
スキャナドライバも同様にインストール。

印刷はさすがにHPより全然きれいで、待機音がありません。
これはGood。電源入っていたか忘れるくらい。
HP複合機で出た「株」の字が印刷できないトラブルは今回解消しました。
場所も取らなくなってとてもうれしい。

カードスロットは残念ながらUSB接続でないと、Ubuntuからは認識しません。
スキャンはGimpか、ターミナルから実行することになります。
残念ですが、MX870のスキャンボタンからはUSB接続していてもスキャンできませんでした。
また、GimpではPDFとしてのスキャンができませんでした。
MX870側からの操作でなら、SDカードやUSBカードにスキャンデータを保存できますが、UbuntuからはUSBメモリは認識できませんでした。
SDカードでスキャンを試してみました。
MX870からの読み込みも、Ubuntuからのディスク認識もできるのですが、読み込み後Ubuntuから抜き差しが必要です。
そしてすごく残念な事に、グレースケールで印刷できません。オプションに無いのです。
結果、単機能プリンタも併用しています。
複合機1台ですべてうまくやるのは難しい。

Tags: ,

[Puppy Linux4.31]無線LAN接続

9月 13th, 2010 by marumi | No Comments | Filed in 周辺機器

UbuntuやgOSで使えた[Buffalo WLI-CB-AMG54]は、差すとドライバを認識したように見えるのですが、スキャンを試みるとフリーズし、再起動もできなくなりました。X serverの起動ができず、再度LiveCDから起動し、Puppyをインストールしなおすハメに・・・。

[WLI-U2-KG54]は、差すだけでOK。接続できました。
でも、このパソコンUSBが一つしか無いので、ここが塞がると不便です。
USBHUB通しても大丈夫かな・・・。

Tags: ,

[Fedora12]ネットワークプリンタ設定

8月 18th, 2010 by marumi | No Comments | Filed in 周辺機器

Fedora12でプリンター設定してみました。

プリンター:HP Officejet Pro L7590
[システム]-[管理]-[add/remove software]で[HPLIP Toolbox]をインストールしておく。
[システム]-[管理]-[印刷]で「プリンタ設定」を開き、「新規」−「デバイス一覧」から「ネットワークプリンタ」をクリックし、「ネットワークプリンタを検索」でプリンタのIPアドレスを入力すると、プリンタが検出されるのでそのままウィザードに従って完了。

プリントサーバ:PCI Mini-101M
プリンタ:CANON PIXUS iP4100
プリントサーバ PCI Mini-101M
↑上記と同様であっさり繋がりました。

 

Tags: , ,

[gOS3.1]プリンター設定

8月 4th, 2010 by marumi | No Comments | Filed in 周辺機器

gOSでプリンター設定してみました。

プリンター:HP Officejet Pro L7590
「追加と削除」で[HPLIP Toolbox]をインストールしておけば簡単。

プリントサーバ:PCI Mini-101M
プリンタ:CANON PIXUS iP4100
プリントサーバ PCI Mini-101M
上記と同様であっさり繋がりました。
内容はUbuntu8.04ですから当然ですが。

続いて「プリントマジック」をセットアップしてみることにしました。
まず、「Adobe AIR」をインストール。
アップデートして、バージョンは3.2.2。
昨年Ubuntuで試した時には、両方のプリンタともハガキ設定での宛名印刷ができず、断念しました。
今回、HPはダメでしたが、CANONの方は宛名印刷に成功しました!
プリントマジックがバージョンアップで対応したのかもしれません。

今年はUbuntuで宛名印刷ができそうです。

Tags: , , ,

[gOS3.1]無線LAN接続

8月 3rd, 2010 by marumi | No Comments | Filed in 周辺機器

無線LANカード:Buffalo WLI-CB-AMG54
カードスロットに差すだけで認識し、gでもaでも接続可能です。
たしかこの無線LANカード、デスクトップをUbuntu9.10にUpdateした時に認識しなくなったような・・・。

Tags:

[Ubuntu9.10]YAMAHAクラビノーバを繋ぐ

6月 9th, 2010 by marumi | 2 Comments | Filed in 周辺機器

UbuntuをUpdateしてから繋がらなくなった電子ピアノをやっと繋ぐことができました。
楽器:YAMAHA CVP-305
接続ケーブル:UX16(USB接続)


お世話になったサイト(深く感謝)。
Ubuntu日本語フォーラム
YAMAHAクラビノーバCVP-305を繋ぎたい
RS232C接続のハードウェアMIDI音源を設定する手順
debian(etch)で外部midi音源を鳴らすには

Alsaのホームページでサポート状況の確認。
http://www.alsa-project.org/main/index. … dor-Yamaha
「UX16」は対応しているようです。

MIDI音源のClient番号、Port番号の確認

~$ aplaymidi -l
Port    Client name                      Port name
14:0    Midi Through                     Midi Through Port-0
20:0    UX16                             UX16 MIDI 1

Client番号:20、Port番号:0となる。

MIDIファイルの再生確認。

$ aplaymidi -p20:0 [midifile_name]

電子ピアノから曲が再生されました。

「Kmidimon」の設定

[Connections]-[Configure Connections]で、Input、Output Connectionを共にUX16:0に設定。
Inputの方は起動する度にクリアされてしまうようなので、入力が必要な時にチェックを入れれば良いと思います。

「Audacious2」の設定
左上のマークをクリック、または右下aマークを右クリックで「Preferences」を開く。
[プラグイン]のデコーダタブで、「AMIDI-Plug 0.8b1」を選択し、画面下部のボタン「設定」をクリック。
ウィンドウ右の「Backend Selection」で「ALSA Backend 0.8b1」を選択。
ウインドウ左の[ALSA backend]をクリック。
「ALSA output ports」を「UX16」にチェック。
「Mixer settings」をSoundcard:UX16に設定。
OKで閉じる。

正直言って、もう一度まっさらから設定してみないと最短の設定方法がわかりません。
今までかなり長い期間、いろんなサイトを見ながらあーでもない、こーでもないといじってました。
効果が無い場合は元に戻したつもりですが、自信ありません。
今回Ubuntu日本語フォーラムに質問を書き込んだところ、どうやらほぼできていたのです。
一人で悩んでいたので気づかなかったんですね。
ともあれ、アドバイスいただいた方々に深く感謝しています。

※参考
usb-midiケーブルの接続確認

$ cat /dev/sndstat
Sound Driver:3.8.1a-980706 (ALSA v1.0.20 emulation code)
Kernel: Linux marumi-desktop 2.6.31-21-generic #59-Ubuntu SMP Wed Mar 24 07:28:56 UTC 2010 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
Intel ICH5 with AD1985 at irq 17
Yamaha UX16 at usb-0000:00:1d.3-1, full speed

Audio devices:
0: Intel ICH5 (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices:
1: UX16

Timers:
31: system timer

Mixers:
0: Analog Devices AD1985
1: mixer10

UX16が存在しているか確認

$ lsusb
Bus 001 Device 003: ID 1871:0306 Aveo Technology Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 0499:1009 Yamaha Corp. UX16 MIDI I/F
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 056e:005e Elecom Co., Ltd
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
$ amidi -l
Dir Device    Name
IO  hw:1,0,0  UX16 MIDI 1

Tags: , ,

[Ubuntu9.10]W-ZERO3 [es] WS011SHを繋ぐ

4月 21st, 2010 by marumi | No Comments | Filed in 周辺機器

WillcomのAdvanced/W-ZERO3 [es] WS011SHをUbuntuマシンに接続成功しました。

まず、リポジトリを追加。

deb http://ppa.launchpad.net/synce/ubuntu karmic main
deb-src http://ppa.launchpad.net/synce/ubuntu karmic main

再読込。
ここで、鍵が無いとエラー発生。

$sudo apt-key adv –recv-keys –keyserver subkeys.pgp.net B152F042D246C25D

で解消して、再読込。

「Synapticパッケージ・マネージャ」で、「synce」で検索して以下のパッケージをインストール。

synce-sync-engine
synce-gvfs
synce-gnomevfs
synce-trayicon
synce-hal
libsynce0
libsynce0-dev
librtfcomp0
python-rtfcomp

PCを再起動。
WS011SHをUSBで接続すると、デスクトップ上に「Mobile Device WM_○○○」が表示され、タスクバーに「Synce Tray Icon」が表示される。

こう書くと簡単なようだが、実際にはすんなりとはいかず、端末から↓こんな入力もしてみた。

$sudo apt-get install synce-hal librra0-tools librapi2-tools
$synce-pls
$synce-pstatus
$sudo apt-get install synce-hal librra-tools
$sudo apt-get install multisync-tools opensync-plugin-evolution opensync-plugin-synce
$msynctool –listplugins
$mkdir ~/.synce/
$cp /usr/share/doc/synce-sync-engine/syncengine.conf.xml.gz .synce/
$gunzip .synce/syncengine.conf.xml.gz
$synce-sync-engine

だが、最後の2行で止まったり、思いついてWS011SHの電源を入れ直したところ接続できました。
なので、結局、どの時点でできていたかは定かでない。
端末開かなくても、電源入れ直せば繋がったのかもしれません。

お世話になったサイト(とっても感謝)
UbuntuとW-ZERO3でファイルのやりとりをする
ubuntuでAdvanced W-ZERO3とシンクする
willcom 03(ws020sh) – Ubuntu PCと同期 〜 SynCE/OpenSync
SynCE with Windows Mobile 5/6/6.1 on Ubuntu

Tags: ,