Posts Tagged ‘Ubuntu’

メインマシンをUbuntuに!-ゴミ箱をデスクトップに表示させる-

5月 8th, 2008 by marumi | No Comments | Filed in インストール・設定

Ubuntuのゴミ箱はとっても小さくて、老眼の私にはつらいです。
そこで、ゴミ箱をデスクトップ上に表示させました。

gconftool-2 –type bool –set /apps/nautilus/desktop/trash_icon_visible true

非表示は、末尾の「true」を「false」にします。

参考サイト(ゴミ箱だけでなくいろんなものをデスクトップに出せます)
Ubuntu Japanese WIKI

Tags: , ,

メインマシンをUbuntuに!-VMware Serverを使う-

5月 8th, 2008 by marumi | No Comments | Filed in インストール・設定

Ubuntuをメインマシンにしたいけど、仕事柄やっぱりWindowsでないとできないことも多いです。
そこで、仮想化ソフトのVMware Serverを入れてみました。

Viva! Ubuntu Magazine vol.8 VMware
を参考に(感謝)、

先にユーザー登録を済ませ、ここまでは良いのですが、ダウンロードから難航しました。
「Synapticパッケージマネージャ」で検索されません。
リポジトリを追加もしてみましたがだめです。
そこで、ヴイエムウェア株式会社のホームページから「VMware-server-1.0.5-80187.tar.gz」をダウンロード。

Ubuntu7.10でVMware Serverを動作させる(難しいケド)
を参考に(感謝)、

$ tar zxvf vmware-server-1.0.4-56528.tar.gz
$ cd vmware-server-distrib
$ sudo ./vmware-install.pl

でも、ダウンロードしたものはデスクトップ上なので、
$ cd /home/ユーザー名/Desktop
でデスクトップ上に移動してから解凍及びインストール。
いろいろ英語で聞かれて、そのままEnterしたり、ライセンスに同意したり、けっこう長いことやって、最後にシリアルナンバーを聞かれたので、メールで届いているシリアルを入力してなんとかインストール完了できました。

その後は、
Viva! Ubuntu Magazine vol.8 VMware
を参考にというかまるっきりそのとおりで(めっちゃ感謝)、

WindowsXP ProfessionalをHDD20MB、メモリは512MB使用で設定し、インストール。

VMware
まるで2台のパソコンのようですが、Ubuntuの中にWindowsがインストールされて、左のモニタに映しています。

これで、通常はUbuntuを使って、どうしても必要な時だけWindowsを呼べば良いです。
WindowsUpdateも完了。わーい、やったー。感動!!

Tags: , , ,

メインマシンをUbuntuに!-フォルダ共有設定-

5月 8th, 2008 by marumi | No Comments | Filed in インストール・設定

もともとこのパソコンは、CドライブとDドライブにパーティションを切ってあり、Ubuntuをインストールする際にもDドライブの領域はFat32で残し、同じネットワーク上のWindowsパソコンからもUbuntuからもアクセスできるようにします。

[システム]-[システム管理]-[フォルダの共有]で設定、初回起動時にsambaとNFSのダウンロード及びインストールを促され、多分sambaだけでも良いかと思いましたが、念のため両方入れておきました。
Ubuntuのインストールの際に、この領域は「/windows」でマウントしてあるので、場所を指定して「読み込み専用」を解除して設定。

samba用のユーザー名・パスワードを設定、端末から、

sudo smbpasswd -a (ユーザ名を入力)
Password:(システム管理用のパスワードを入力)
New SMB password:(Winマシンからアクセスするときのパスワードを入力)
Retype new SMB password:(確認の為もう一度入力)

参考サイト(毎度お世話になってます、感謝)

UbuntuとWindowsでフォルダ共有

Tags: ,

メインマシンをUbuntuに!-7.10にアップグレード-

5月 8th, 2008 by marumi | No Comments | Filed in インストール・設定

バージョン8.04から7.04に変えたのは、間に7.10があることを忘れていたのでした。
前にダウンロードしたCDが7.04だったので、それが前バージョンと疑いもなくインストールしてしまいました。
仕方ないのでアップグレード。ネットワーク経由でのアップグレードはBフレッツマンションタイプではえらく時間がかかって、これもインストールCDをダウンロードしてクリーンインストールしたほうが良かったような気がします。
あまりに長いので、ほっといて寝てしまいました。

アップグレード途中で、「defaults.listを置き換えますか?」とか、いろいろ置き換えますか?って聞かれる。
前にノートパソコンの7.04で何も考えずに7.10にアップグレードして失敗したのを思い出しました。
たしか、そのままEnterを押していった。Enterだと置き換えないほうだったのね。
それで起動しなくなったのか・・・(汗)。

ドキドキしながら再起動。
「Ubuntu is running in low-graphics mode」ですと。
ビデオカードがまたダメになりました。
一応起動しますが、2台のモニタに同じ内容が表示されています。
7.04を入れた時は1台しかまともに映りませんでしたが。
リポジトリを「Feisty」から「gutsy」に変更して、日本語セットアップヘルパを実行。
ビデオカードは「制限付きドライバの管理」では使用中になってますが、これは古いドライバでしょう。
今度はEnvyで入れてみます。

Envyは起動すると何かファイルが無いとかで、インストールし直してみますか?と聞かれるのでOK。
完了後、そのままNVIDIAのドライバをインストールして再起動すると、マルチモニタの設定も正常に動作しました。

起動時に「Xウインドウのキーボード設定が現在のGNOMEの設定と異なります・・・どちらの設定を利用しますか?」と出る。
「GNOMEの設定に従う」をクリックして再起動すると、やっぱり聞かれる。
キーボードは最初USキーボードになっていたので修正済み。
ネットでググってみるとどうやらたまにある障害らしい。
でも、「Xの設定に従う」をクリックしてみたら、出なくなった。

参考サイト
おさるのパソコン備忘録
Ubuntu日本語フォーラム

Tags: , ,

メインマシンをUbuntuに!-ビデオカード設定とマルチモニタ-

5月 7th, 2008 by marumi | No Comments | Filed in インストール・設定

なかなか手を焼いたビデオカード(NVIDIA GeForceFX5500)の設定。

これは実は私の勘違いでした。
もともと、マルチモニタにしてあるのが、当然未設定では片方しか映らないわけで、映らないほうはチカチカして目ざわりなので、モニタの電源を切っていたのです。
で、NVIDIAのドライバを入れると、その切っているほうのモニターがメインに切り替わっていて、それなのにモニタの電源を落としているから画面は真っ暗だったのでした。ああ、早く気付けよ。

気付かずにいろんな方法でドライバインストールしました。

参考:
Ubuntu/NVIDIA
Linux(ubuntu)にnvidiaドライバを一発でインストール
ひねもすLinux

で、マルチモニタの設定。

NVIDIAのドライバが入ると、[アプリケーション]-[システムツール]に[Nvidia Settings]というツールがインストールされます。
これで、マルチモニタの設定をします。

「X Server Display Configuration」で、Layoutを調整。
「Configuration」は「TwinView」にすると、両方のモニタが表示されました。
「Separate X Screen」で設定しても有効になりません。

それに、再起動すると元に戻ってしまい、マルチモニタになりません。

どうやら「Save to X Configration File」をクリックした際に、「Unable to create new X config backup file ‘/etc/X11/xorg.conf.backup’.」と出て、設定が保存されていない様子。
どうしてバックアップが作れないのかわからないけど、要するに「xorg.conf」が書き換われば良いのだから、端末で直に編集してみる。内容は「Save X Configuration」の「Show preview」で表示されるのでそのままコピー。
DVI接続のモニタのほうをプライマリに設定。

これでマルチモニタ設定ができました。ホッ。

※追記
設定が保存されないのは管理者権限で操作していない為でした。

$ sudo nvidia-settings

で起動すれば保存できるのでした。

Tags: , , , ,

メインマシンをUbuntuに!-バージョンを7.04に-

5月 7th, 2008 by marumi | No Comments | Filed in インストール・設定

Ubuntu Ver.8.04を入れてみたものの、ビデオカードのインストールがうまくいかず、Firefox 3BetaをアンインストールしてFirefox2を入れたものの「Google toolbar」や「Google Browser Sync」 がインストールできないトラブルに見舞われ(インストールする権限が無いとか言われちゃう)、「Google Browser Sync」が使えないと、ブックマークが使えず効率が悪すぎる。
まだ8.04では情報も少ないので、いい加減ググるのも疲れてしまい、前のバージョンの7.04を入れ直すことにした。
アップデートがたくさんあって、すんごく時間はかかったけど、Firefoxはこれで解決。

Tags: , ,

メインマシンをUbuntuに!-インストール後の設定-

5月 5th, 2008 by marumi | No Comments | Filed in インストール・設定

インストール完了後にやっておくことを整理。

■リポジトリを取得するサーバーを最適なところに変えておく。

[Synapticパッケージ・マネージャ]→[設定]→[リポジトリ]でダウンロード元を「最適なサーバーを探す」で検索して変更。

■日本語版セットアップ・ヘルパ実行

[Synapticパッケージ・マネージャ]を起動し、[設定]→[リポジトリ]の[ダウンロード元]を[日本サーバ]から[メインサーバ]に切り替えて、次に、[システム]→[システム管理]→[日本語版セットアップ・ヘルパ]を実行。

■ビデオカードの認識がされていない(NVIDIA GeForceFX5500)。

[システム]→[システム管理]→[ハードウェアドライバ]には、「このシステムではプロプライエタリなドライバは利用されていません。」と出て、かまわず有効にするにチェックを入れて再起動したら、Ubuntuが起動できなくなってしまった。画面は真っ暗なまま。
えーん、やり直し。

こういう時の為に、「xorg.conf」はバックアップを取っておく。
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

戻す時は、
sudo cp /etc/X11/xorg.conf.bak /etc/X11/xorg.conf

でも、今回は起動できなくなってしまったので、インストールCDから起動して
sudo cp /media/disk/etc/X11/xorg.conf.bak /media/disk/etc/X11/xorg.conf

うーん、どのパソコンもこれで引っかかる。

■コーディックインストール
端末で「sudo apt-get install libdvdcss2 w32codecs」

今回は音は最初から出ていた。
市販のDVD OK
ユーチューブ OK
Flash OK

Tags: ,

メインマシンをUbuntuに!-パーティション-

5月 5th, 2008 by marumi | No Comments | Filed in インストール・設定

PC:自作
OS:Ubuntu8.04
CPU:Pentium4 2.80GHz
HDD:120GB
Memory:1022MB

このパソコンはCとDとにパーティションを切ってあり、CドライブにWindowsXP、Dドライブに主なデータを保存している。
Dドライブは残して、CドライブにUbuntuをインストールしたい。
失敗する可能性もかなり高いのでもちろんバックアップは取る。
Ubuntu8.04はパーティション分割なしでデュアルブートができるようだけど、それだとWindowsを再インストールした時にどうなってしまうのか疑問なので、とりあえずUbuntuをメインでインストールすることに。

UbuntuのインストールCDを入れて、インストール開始。
パーティションの設定で悩む。
Dドライブのサイズを小さくしてCドライブを大きくしたかったんですが、うまくいかないのでいったん削除(やっぱり・・・)。
Dドライブが心配なので、一旦インストールを中止し、慣れているWindowsを起動してDドライブを確保。
XPのフォーマットはNTFSでしかできないので、フリーソフトの「Fat32Formatter」で、fat32フォーマット。
多分UbuntuのインストールCDでやれば良いのだけど、自信が無いので戻れるうちはWindowsに戻ってしまう。
これがいけない。

Cドライブのパーティションを削除してから、「ガイド-最大の連続空き領域を使う」を指定してインストールしましたが、なぜか小さいほうの未使用領域にインストールされてしまった。
しかもBootにWindowsXPが残ってる(起動はできない)ので、再度インストールやり直し。
今度はパーティションを「手動」を指定して、Cドライブの領域にext3形式で、マウントポイント「/」を指定して、残りを「/home」に指定してインストール。
今度は成功。

Tags: ,

メインマシンをUbuntuに!-準備-

5月 3rd, 2008 by marumi | No Comments | Filed in インストール・設定

メインマシン(自作)がこの頃どうも調子が悪い。
exploreが頻繁にフリーズする。
パソコン本体から音がすることがある。
ここらで、OSをクリーンインストールし直そうかとも考えたけど、それならいっそUbuntuを入れちゃおうか!と考えた。
WindowsXPも仕事上必要なので、デュアルブートにするか、仮想化ソフトを使うか・・・。

とにかく大工事なのだ。なにしろメインマシンだから、何かコピー漏れがあっては困る。
念の為、別のPCにメインマシンの環境を全部コピーする。
そして、数日そのまま使ってみる。
そうすると、やっぱり見落としはあるもので、それを一つづつ潰していく。
その間にメインマシンのメモリを増設(これはついで)。

Ubuntuの8.04が出ているので、日本語ローカライズ版をダウンロードしてCDに焼いておく。
いろいろ変わったと思うので情報収集しつつ、Windowsとのからみをどうするか検討。

Tags: ,

FMV-BIBLO MR16BをUbuntuで無線接続

7月 15th, 2007 by marumi | No Comments | Filed in インストール・設定

Ubuntuを入れたノートパソコン、せっかく無線が内蔵なので接続を試みてみましたが、ネットワーク接続を確認すると、有線接続と認識されている様子。
これでは繋がりません。

このパソコンの内蔵無線は「IEEE 802.11」チップセットは「Prism2.5 Wavelan chipset」。
なんでも、バグがあるらしい。
hoge256ブログ←こちらを参考に、と言うかまる写しさせていただき、設定できました。
感謝。

以下は備忘録。

コマンド入力で

sudo modprobe -r orinoco_pci
sudo modprobe -r hostap_pci
sudo modprobe -r prism2_pci
sudo modprobe orinoco_pci

このままだと再起動した時に元に戻ってしまうので、 /etc/modprobe.d/blacklist に下記の記述を追加。

blacklist prism2_pci
blacklist hostap_pci
blacklist hostap

Tags: , ,